Back to overview
Degraded

High Server Load

Jan 28 at 03:05am GMT
Affected services
Core Backend Services

Resolved
Jan 28 at 05:46am GMT

Our infrastructure has been adjusted to handle the traffic and all requests should now be completing successfully.

Created
Jan 28 at 03:05am GMT

We're encountering an unusually high server load for the current period which is causing some issues to receive delayed or failed responses. If you encounter any issues, please try again soon!